Just starting out with functional programming and wondering if there's a better way to write this. The nested map function calls can get quite hard to read :p TypeScript
type $parse = (text: string) => string[][][];
const parse: $parse = pipe(split("\n\n\n"), map(pipe(split("\n\n"), map(pipe(split("\n"), filter(isNotEmpty)))));
Appreciate any advice, thank you :)